Component Minimum Recommended Recommended for Production
PHP Latest 5.5.x Latest 5.6.x or 7.0.x
Database Latest MySQL 5.5.x MariaDB 10.1.x or Percona Server 5.6.x or above
Web Server Latest Apache 2.2.x Latest NGINX 1.8.x or above
Такие требования к установке modx revolution. Но вот вопрос — подойдет ли версия php 7.2.3?
Или обязательно нужно использовать php 7.0.28?

Вообще какая разница для modx между разными версиями php 7?
И если уже используется modx revo 2.6.1 (php 7.0.27) то обновление на modx 2.6.2 требует php 7.2 и выше или необязательно?

Также при обновлении почему то не ставится галочка Обновление существующей установки, соответственно не получается обновить (с версии 2.6.1 на 2.6.2 xampp php 7.0.27).